[Top] [All Lists]

Re: Error :Nomatch found in TLB ?????

To: "Srinivas JT." <>
Subject: Re: Error :Nomatch found in TLB ?????
From: Geert Uytterhoeven <>
Date: Wed, 21 Jul 2004 16:44:06 +0200 (MEST)
Cc: Linux/MIPS Development <>
In-reply-to: <>
Original-recipient: rfc822;
References: <>
On Wed, 21 Jul 2004, Srinivas JT. wrote:
> I tried to load my .serc file into my Db1500 SDB. The steps that I followed 
> are,
> 1) I wrote a filein C(Linux).
> 2) I generated an object file using gcc.

Using the plain `gcc' command, I guess?

> 3) By using objcopy I converted my obj file into srec file.
> 4) Then I tried to download my srec file into Db1500 SDB in Yamon using tftp.
> then I got error as,
> Error: No match in TLB for mapped address  : Address = 0x00000000
> Why I am getting this error ?. Is any error there in my procedure..?

By default gcc creates ELF files for a virtual memory OS. Hence the load
address (0x00000000) is virtual as well.

You have to explicitly tell the linker to create an image to be loaded at a
specific address, cfr. arch/mips/kernel/



Geert Uytterhoeven -- There's lots of Linux beyond ia32 --

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
                                                            -- Linus Torvalds

<Prev in Thread] Current Thread [Next in Thread>