[Top] [All Lists]

Re: help needed : cannot install linux on SGI O2 R5000

Subject: Re: help needed : cannot install linux on SGI O2 R5000
From: Kumba <>
Date: Fri, 28 May 2004 17:14:54 -0400
In-reply-to: <>
Original-recipient: rfc822;
References: <>
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113
Max Zaitsev wrote:

this I've tried already, but the thing is that the netboot kernel does not go beyond telling me what the entry point was. I've also tried to use the kernel from Ilya with the same root. There, everything would hang after starting the initrd script.

Since you're on the framebuffer, likely the kernel was attaching to the serial console to display it's messages, thus why you didn't see any messages after the entry point.

actually, I don't. I don't have a serial console/cable in my possetion and was intending to actually use the display/keyboard combination to perform the installation. Would it be possible? Can you advise me where to get a suitable netboot kernel?

The framebuffer is still a bit flakey last I heard. The netboot I have supports the netboot, but I have no idea how well it works. Likely, it'll be several revisions of the kernel before the framebuffer becomes stable.

The O2 itself uses a standard DB9M connector, so it should be rather easy to obtain a cable and null-modem adapter to do serial console with for the machine. Far easier than hunting down the obscure serial connectors for IP22 machines. Serial, for now, my reccomended form of installing -- it'll be a lot less painless, IMHO.

Lastly, the netboot I have is geared for a gentoo install, if that's what you'll be installing, you'll want to aim any gentoo-specific questions to the gentoo-mips ML. If it's a debian install, then you might be in for a fun ride or such, but I believe they are working on an O2 netboot of their own w/ the d-i setup and such.


"Such is oft the course of deeds that move the wheels of the world: small hands do them because they must, while the eyes of the great are elsewhere." --Elrond

<Prev in Thread] Current Thread [Next in Thread>