[Top] [All Lists]

2.4 kernels + >=binutils-

Subject: 2.4 kernels + >=binutils-
From: Kumba <>
Date: Mon, 08 Mar 2004 18:26:42 -0500
Original-recipient: rfc822;
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113

Having an odd issue with booting 2.4 kernels built with binutils- and newer on an Indy R5000:

System Maintenance Menu

1) Start System
2) Install System Software
3) Run Diagnostics
4) Recover System
5) Enter Command Monitor

Option? 5
Command Monitor.  Type "exit" to return to the menu.
>> ls
2422x0  2425p6x1  2603x0  arcboot  2425x0  2423x0  2422x1
/dev/sda3/: no such device
>> boot -f 2425x0

Cannot load scsi(0)disk(4)rdisk(0)partition(8)/2425x0.
Text start 0x8000000, size 0x194400 doesn't fit in a FreeMemory area.
Unable to load 2425x0: ``2425x0'' is not a valid file to boot.

This issue started appearing with binutils-, and still exists in binutils- If I downgrade to binutils-, the issue goes away (This is a cross-compiled kernel, btw). So this seems to be a binutils-specific issue. I'm not sure what the change was that led to this. Any binutils people have an idea or need more test data run?

For reference, the compiler used was gcc-3.3.3, and has been tried on 2.4.22, 2.4.23, and 2.4.25 kernels. I haven't tried it with 2.6.x kernels yet. Other binaries built with these binutils don't seem to show any outward signs of problems, just seems to be kernels.


"Such is oft the course of deeds that move the wheels of the world: small hands do them because they must, while the eyes of the great are elsewhere." --Elrond

<Prev in Thread] Current Thread [Next in Thread>