[Top] [All Lists]

IDE driver problem

Subject: IDE driver problem
From: "Liu Hongming (Alan)" <>
Date: Tue, 24 Feb 2004 13:09:48 +0800
Original-recipient: rfc822;

Hi All,

I am porting IDE drivers(Since my hardware has endian issue),
and now it could work,however it has some abnormal problems:

I could 'fdisk'  /dev/hda,and partition it into several partitions.
After this,I reboot my board and see all the partitions is there.
Then I 'mke2fs' on /dev/hda1,after this, when using 'fdisk' again,
I found all partitions gone! At this time,I could not access /dev/hda1
any more.However, I could 'mount /dev/hda /opt', it really worked,and
I could create/read/write/erase files in it.

I dumped the first sector of Hard disk and found that it has been
zeroed.Now I dont know what the problem is,since I am not familiar
with fs parts of linux kernel,and I dont know what 'mke2fs' has done.

Any advice?


-----Original Message-----
From: Kevin D. Kissell []
Sent: Tuesday, February 24, 2004 6:47 AM
To: Mark and Janice Juszczec;
Subject: Re: r3000 instruction set

Kaffe's makefiles won't pick up on configuration changes, so any time
you re-configure for a different engine or debug level, you need to do
a make clean.  At least, that's the way it was the last time I worked on it.
If you had a partial build with JIT, then changed to intrp, then you could
get all kinds of strange behavior.  The address range of your error us a
dead giveaway.  It's too high to be the kaffe code segment, but too low
to be a shared library.  It's where I'd expect the heap to be, and where
I remember the JIT buffers being allocated when I was trying to debug
that stuff.

> Its been a few weeks since I built this version of kaffe.  The configure
> output says I did specify --with-engine=intrp.  I'll delete the compiled
> stuff, reconfigure (double checking that I give it --with-engine=intrp),
> recompile and retest.
> I'll post my results.
> Mark
> >From: "Kevin D. Kissell" <>
> >To: "Mark and Janice Juszczec" <>,       
> ><>
> >CC: <>, <>, <>
> >Subject: Re: r3000 instruction set
> >Date: Mon, 23 Feb 2004 18:21:19 +0100
> >
> > > Someone suggested posting the message I get.  Here it is:
> > >
> > > >./kaffe-bin FirstClass
> > > [kaffe-bin:6] Illgal instruction 674696a at 2abb034, ra=2adbffd0,
> > > P0_STATUS=0000500
> > > pid 6: killed (signal 4)
> > > >Reading command line: Try again
> > > Kernel panic: Attmpted to kill int!
> >
> >Let me guess.  You are running little-endian.  The instruction word
> >in memory would be 0x6a697406.  Do you think it's a coincidence
> >that 0x6a6974 spells "jit" in ASCII?  ;o)
> >
> >The reported address range looks like that where kaffe builds its
> >JITted instruciton buffers in MIPS/Linux.  And, like I say, JIT is
> >somewhat broken for MIPS in Kaffe.  Which version of the kaffe sources
> >are you building, and have you tried configuring with --with-engine=intrp
> >as I suggested?
> >
> >             Regards,
> >
> >             Kevin K.
> _________________________________________________________________
> Click, drag and drop. My MSN is the simple way to design your homepage.

<Prev in Thread] Current Thread [Next in Thread>