[Top] [All Lists]

Problems with LCD panel & SCSI support with Linux 2.4.24-pre2 on Cobalt

To: Linux MIPS Mailing list <>
Subject: Problems with LCD panel & SCSI support with Linux 2.4.24-pre2 on Cobalt Qube II
From: Stuart Longland <>
Date: Mon, 02 Feb 2004 00:01:10 +1000
Original-recipient: rfc822;
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007
Hash: SHA1

Hi All,
        Just the other day, I dragged out the old Gateway Microserver I have
here (a rebadged Cobalt Qube II) with the idea of setting it up as a

        I opened the box and dropped in an Advansys PCI SCSI card (I don't
recall the exact model) into the PCI slot, with the intent of hooking up
external SCSI drives.  I also replaced the HDD with a 40GB IBM Deskstar
I had sitting around.  On loading Debian Woody, I discover that there is
no SCSI support in the kernel, so I set about building one.

        Managed to cross compile 2.4.18 with the media patches, etc -- All
seemed to work, apart from SCSI.  modprobe advansys would complain that
the card was not present.  I also experienced hard lockups when I tried
dumping some large files to it over the LAN.

        Upgraded it to Linux 2.4.24-pre2 (CVS checkout from linux-mips done 6th
January, 2004) -- This seems to have corrected the hard lockups I had
previously, however, the SCSI card still doesn't work and now the LCD
panel on the back no-longer functions.

        I have uploaded what information I have (including output from
logfiles, lspci output, modprobe output, my toolchain versions, the
kernel config used, etc) to

        The toolchain was created on a i686-pc-linux-gnu host using the script on Gentoo Linux.  The kernel used was patched using
patches from

        Is there anything I might have missed in trying to set this up?  I'm
fairly new to the MIPS architecture, this is the first time I managed to
get a custom MIPS kernel to boot correctly in a usable manner.  I've
noticed comments that the Cobalt support is suffering some "bit rot" and
hence, it has been quite shakey lately (well, for me anyway), however
I'd like to help out with ironing out these problems if possible.

- --
| Stuart Longland           stuartl at |
| Brisbane Mesh Node: 719    |
| I haven't lost my mind - it's backed up on a tape somewhere |
| Atomic Linux Project    <---> |
Version: GnuPG v1.2.2 (GNU/Linux)
Comment: Using GnuPG with Mozilla -


<Prev in Thread] Current Thread [Next in Thread>