[Top] [All Lists]

Re: Trouble compiling MIPS cross-compiler

Subject: Re: Trouble compiling MIPS cross-compiler
From: Adam Nielsen <>
Date: Sun, 18 Jan 2004 16:46:04 +1000
In-reply-to: <>
Original-recipient: rfc822;
References: <200401171711.34964@korath> <200401181510.35686@korath> <>
User-agent: KMail/1.5
> I'd recommend the following:
> binutils- (or you can try the latest .8 release, it has some
> more mips fixes in it)
> ...
> gcc-3.3.2

Thanks for all the info!  Well, I tried building gcc-3.3.2 with your options 
and that worked (hooray!) but I couldn't find binutils-, the 
closest I could see was 2.14 so I used that.  It all compiled ok, but now 
when I go to compile the kernel I get this error:

cc1: error: invalid option `cpu=r3000'

If I copy the command line and change -mcpu to -march then it works fine, but 
this isn't happening automatically for some reason.  Any ideas?  (I tried 
downgrading to but it still gave the error, so I'm guessing 
it's a gcc problem - oh how much easier life would be if they didn't remove 
the -mcpu option somewhere along the way ;-))


<Prev in Thread] Current Thread [Next in Thread>