[Top] [All Lists]

Re: Kernel 2.4.23 on Cobalt Qube2

Subject: Re: Kernel 2.4.23 on Cobalt Qube2
From: Rainer Canavan <>
Date: Tue, 9 Dec 2003 23:03:51 +0100 (CET)
In-reply-to: <>
Original-recipient: rfc822;
Reply-to: Rainer Canavan <>
> Has anyone got a 2.4.23 kernel running on the Cobalt Qube 2 ?

Not on a Qube2, but on a nasraq, which is essentially the same, just
without the second ethernet port and the pci slot but a scsi port instead.
Last kernel I tried on my Qube2 seems to be 2.4.22-rc2.

Works fine, as far as I can tell.
> I've cross compiled the latest kernel from CVS (using the default Cobalt 
> config in the tree) on a PC using gcc 2.95.4 and binutils 
> (both from Debian sources).
For me, it's 2.95.4-15 and, and I'm compiling my kernels

> The kernel boots okay from the HD, but I get strange segmentation faults 
> and other errors whilst running Debian's "dpkg" to install packages. If 
> I repeat the installation from scratch I get exactly the same errors in 
> exactly the same places :-(

I just tried updating, removing and installing a package without 
any problems.
> I've changed both the memory SIMMs for new ones and the problem is still 
> the same. I've done the same Debian install on an Au1100 board with no 
> problems at all.
> Neither of the on-board ethernet ports work correctly with new kernel 
> either. The primary port seems to work fine pinging single packets back 
> and forth, but seems to stall for periods of approx 20 seconds when 
> performing bulk transfers. I've been using an RTL8139 card in the PCI 
> slot for network access.

I haven't tried my Qube2 yet, since that one's already wrapped up and
ready for Karsten Merker to pick up - he's going to send it to the 
Tulip Expert, so those problems may go away soon, hopefully. As to 
kernel versions starting about 2.4.17, I've never had the tulip driver
running reliably on my Qube2, but always got at least 2.4.18 and later 
working properly on my nasRaq (there was some patching involved at times, 
if I recall correctly).


<Prev in Thread] Current Thread [Next in Thread>