[Top] [All Lists]

Re: Newbie R5K questions -- -mips2 vs -mips4; is n32 ABI supported by Li

To: Jeffrey Baitis <>
Subject: Re: Newbie R5K questions -- -mips2 vs -mips4; is n32 ABI supported by Linux?
From: Daniel Jacobowitz <>
Date: Mon, 17 Nov 2003 17:29:40 -0500
Cc:,, "Mr. Brian R. Gunnison" <>, Francis Yu <>, Johnny Lam <>
In-reply-to: <1069106666.1829.323.camel@powerpuff.evo1.pas.lab>
Original-recipient: rfc822;
References: <1069106666.1829.323.camel@powerpuff.evo1.pas.lab>
User-agent: Mutt/1.5.1i
On Mon, Nov 17, 2003 at 02:04:26PM -0800, Jeffrey Baitis wrote:
> Hi all:
> I'm currently trying to increase performance on our PMC-Sierra RM5231
> system by taking advantage of the MIPS IV ISA. This processor has a
> 32-bit address bus interface with 64-bit GPRs, so I guess that the
> choice of -mabi=n32 is ideal for this processor.
> Why is it that the Linux kernel defaults to -mcpu=r5000 -mips2 for the
> 52XX? Wouldn't there be good reasons to use the enhancements present in
> the MIPS IV instruction set?
> I've tried modifying the mips Makefile so that the Nevada adds the
> cflags -mabi=n32 -mcpu=r5000 -mips4. I also modified asm/unistd.h so
> that __NR_sigreturn is defined for the case where _MIPS_SIM ==
> _MIPS_SIM_NABI32. Unfortunately, I get link errors: (gcc 3.2.3)
>         arch/mips/kernel/kernel.o(.data+0x4240): undefined reference to
>         `sys_stat64'
>         arch/mips/kernel/kernel.o(.data+0x4244): undefined reference to
>         `sys_lstat64'
>         arch/mips/kernel/kernel.o(.data+0x4248): undefined reference to
>         `sys_fstat64'
>         drivers/ide/idedriver.o(.data.init+0x8): undefined reference to
>         `init_setup_it8172'

Do not even attempt to run an n32 kernel.  Use a 64-bit kernel (you
can't just say -mabi=n64, of course!  See ARCH=mips64 in 2.4 or
CONFIG_MIPS64 in 2.6).

> The goal is that I want to be able to execute MIPS IV or MIPS III
> instructions in user mode, since the profiling program that I'm using is
> based in userspace and does not measure kernel performance. I already
> have measured performance using MIPS I binaries. Under a -mips1-compiled
> uClibc/busybox root filesystem, I tried executing -mips2, -mips3, and
> -mips4 binaries -- but it seemed that the ELF interpreter was unable to
> recognize them as valid ELF files (resulting in a shell 'Syntax Error').
> After doing some digging, I found some documentation on SGI's website
> about different ABI levels:
> Here, I read that the OS, my libraries, and, of course, the application
> must support the ABI of my choice. So, this takes me to my second
> question: does Linux support the n32 ABI? How do I enable this support,
> so that it is possible to take advantage of MIPS IV instructions?

Currently, the tools are just beginning to support n32 and n64 user
programs.  No released version of binutils, gcc, or glibc contains the
support.  Current CVS versions may or may not.

Daniel Jacobowitz
MontaVista Software                         Debian GNU/Linux Developer

<Prev in Thread] Current Thread [Next in Thread>