[Top] [All Lists]

Re: Oddities with CVS Kernels, Memory on Indigo2

To: Kumba <>
Subject: Re: Oddities with CVS Kernels, Memory on Indigo2
From: Ladislav Michl <>
Date: Tue, 15 Apr 2003 09:50:34 +0100
In-reply-to: <>; from on Tue, Apr 15, 2003 at 04:35:23AM -0400
Original-recipient: rfc822;
References: <> <20030414140717.GA805@simek> <>
User-agent: Mutt/
On Tue, Apr 15, 2003 at 04:35:23AM -0400, Kumba wrote:
>       A question with the CVS Kernel.  Are there any known issues as to the 
> specific toolchain used to build it?  Currently I'm using GCC 3.2.2 + 
> Glibc 2.3.2 + Binutils  I tried a CVS updateshortly after 
> testing this kernel, and it still doesn't boot, so either my timing is 
> really bad, or I'm using a toolchain with known issues.  I have noticed 
> the toolchain does not support -mcpu in .18 of binutils, and I 
> originally thought this was only going to be a GCC change in 3.3, but my 
> guess if it's the same in .18/.20, and as such I'll need to use the 
> instructions posted about a month about to use -mabi/-march?

silly question: you specified -r linux_2_4 when checkouting kernel, didn't
you? otherwise you are trying to boot 2.5.47, which has broken serial console

anyway, toolchains i'm using to build 32-bit kernel:
$ mips-linux-gcc -v
Reading specs from /home/ladis/mips-tools/lib/gcc-lib/mips-linux/3.2/specs
Configured with: ../gcc-3.2/configure --prefix=/home/ladis/mips-tools 
--disable-shared --with-gnu-as --enable-languages=c --disable-nls --with-newlib 
--enable-checking=no --disable-threads 
--with-headers=/home/ladis/src/linux/include --target=mips-linux
Thread model: single
gcc version 3.2
$ mips-linux-ld -v
GNU ld version 2.13

64-bit kernel (egcs is patched with egcs-1.1.2.diff.gz from ftp):
$ mips64-linux-gcc -v
Reading specs from 
gcc version egcs-2.91.66 19990314 (egcs-1.1.2 release)
$ mips64-linux-ld -v
GNU ld version 2.13


<Prev in Thread] Current Thread [Next in Thread>