[Top] [All Lists]

Re: Oddities with CVS Kernels, Memory on Indigo2

Subject: Re: Oddities with CVS Kernels, Memory on Indigo2
From: Kumba <>
Date: Mon, 14 Apr 2003 11:53:47 -0400
In-reply-to: <20030414140717.GA805@simek>
Original-recipient: rfc822;
References: <> <20030414140717.GA805@simek>
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Ladislav Michl wrote:
I'd say you've tried cvs kernel at the times when support for R4400
caches was broken. I put kernel I'm currently running at (gunzip it :)), as you can
see from dmesg at the end of this mail CPU used in your machine is the
same. If kernel I provided doesn't boot for you I'd like to ask you for
help with debugging (kernel was build from cvs updated at 8:30 CEST)

Wow, this booted. Several people I talked to thought it was originally a serial console issue. Judging by the several times I've chosen to build a kernel, it seems R4400 cache gets broken quite often. I'll run a cvs sync now and try to build my own kernel, since this appears to be built from recent code. Your kernel lacked a few things gentoo requires to boot, but it at least proves I'm not going insane over here.

This is known bug, but unfortunately I have not enough RAM to meet it...

A known bug? Interesting. I mentioned it many moons ago in #mipslinux, and Ralf seemed curious about it, but he said he looked in the kernel where the memory was detected and said he didn't see anything wrong there. Anything I can do to help look into this bug and possibly fix?

parport0: PC-style at 0x278 [PCSPP,TRISTATE,EPP]

it can't work ;)

It worked fine for me with printing :)

[root@angband root]# echo "Hello World" > /dev/lp0
[root@angband root]# echo "Wow, It works" > /dev/lp0
[root@angband root]# echo "Totally Cool" > /dev/lp0

^--- All printed out on paper, although scratchy. I need new ink cartridges. Canon BJC-620

Mind you, that's an ISA Parallel Port card I dropped in. I noticed the SGI's parallel port never worked, so I dug up a spare and tried it.


<Prev in Thread] Current Thread [Next in Thread>