[Top] [All Lists]

ext3 problem solved

To: Linux MIPS mailing list <>
Subject: ext3 problem solved
From: Hartvig Ekner <>
Date: Fri, 11 Apr 2003 19:55:23 +0200
Original-recipient: rfc822;
I found out (sort of) what the problem was and found a fix.

Apparantly there is something wrong with e2fsprogs 1.27, since it was unable to 
the problem I had in the filesystem (just kept repairing the same thing again 
and again).

I took the disk and attached it to a x86 PC, and ran fsck.ext3 there (an older 
version, 1.26).
It found exactly the same errors as the MIPS system, but actually fixed them so 
subsequent runs with "-f" reported no errors. I then put the disk back on the 
system - voila, no more filesystem problems. Then did another unclean shutdown,
and the same problem reappeared, and once again fsck (on MIPS) was unable to fix

Then I downloaded e2fsprogs-1.32-6.mipsel.rpm from redhat 9, and installed that 
on my
MIPS system. And that removed the problem for good.

So the conclusion must be: The e2fsprogs-1.27 package which is part of the MIPS 
RedHat distribution (CDROM and FTP) is broken. Don't leave home without a newer
e2fsprogs RPM just in case!

Thanks to everybody who replied!


<Prev in Thread] Current Thread [Next in Thread>
  • ext3 problem solved, Hartvig Ekner <=