[Top] [All Lists]

Re: [patch] VR4181A and SMVR4181A

To: Julian Scheel <>
Subject: Re: [patch] VR4181A and SMVR4181A
From: Yoichi Yuasa <>
Date: Mon, 17 Feb 2003 10:51:15 +0900
In-reply-to: <>
Organization: MontaVista Software Japan, Inc.
Original-recipient: rfc822;
References: <> <>
Hi Julian,

On Sat, 15 Feb 2003 11:17:16 +0100
Julian Scheel <> wrote:

> Hi,
> I'm using the config, which is provided as arch/mips/defconfig-smvr4181a. The 
> kernel is the 2.4-release (cvs -rlinux_2_4) form
> Compiling works fine for some time, but then I get this error:
> jscheel/Programmieren/cmms/linux/include/asm/gcc -G 0 -mno-abicalls -fno-pic 
> -pipe -mcpu=r4600 -mips2 -Wa,--trap   -nostdinc -iwithprefix include 
> -DKBUILD_BASENAME=pmu  -c -o pmu.o pmu.c
> {standard input}: Assembler messages:
> {standard input}:125: Warning: Tried to set unrecognized symbol: vr4100
> {standard input}:126: Error: opcode not supported on this processor `standby'
> make[1]: *** [pmu.o] Error 1
> make[1]: Leaving directory 
> `/home/jscheel/Programmieren/cmms/linux/arch/mips/vr4181a/common'
> make: *** [_dir_arch/mips/vr4181a/common] Error 2
> Is this a problem with your patch or perhaps with my cross-compiler? (Depends 
> it on GCC 3.x?)

-m4100 option can be tried supposing you are using gcc
which has a problem as the present option.

Please change following line.

GCCFLAGS        += -mcpu=r4600 -mips2 -Wa,-m4100,--trap

Please let me know what the result became.


<Prev in Thread] Current Thread [Next in Thread>