[Top] [All Lists]

Re: problem with big endian binutils..?

To: atul srivastava <>
Subject: Re: problem with big endian binutils..?
From: Ralf Baechle <>
Date: Tue, 12 Nov 2002 18:48:12 +0100
In-reply-to: <>; from on Tue, Nov 12, 2002 at 01:22:57PM -0000
Original-recipient: rfc822;
References: <>
User-agent: Mutt/
On Tue, Nov 12, 2002 at 01:22:57PM -0000, atul srivastava wrote:

> Have anybody confirmed stability of binutils for big endian 
> mips?
> while little endian gives me no problem
> but i am simply unable to make a working big endian ramdisk.
> specific problem is in identifying the e_type and e_machine fields 
> in elf header of executables.
> expected value of e_type is 0x2(ET_EXEC) amd e_machine is 
> 0x8(EM_MIPS)
> but those are read as 0x200 and 0x800 respectivly ..this is 
> obviously the endianness problem.

Possibly a problem in your reader.  Are you using od to look at the
header?  Od is dumping in the byteorder of the machine it's running on.

> I have tried big endian ramdisk from 
> and also tried compiling one using uclibc package , both
> failed because of same reason.
> when i run file command on those executables after mounting the 
> ramdisk on my host i get o/p like
> ELF 32-bit LSB executable, MIPS R3000_BE - invalid byte order, 
> version 1, statically linked, stripped

The error message you're seeing simply means byte 5 of the ELF file is
zero that is unset that is not specifying any endianess.

> though i see lot of mails regarding "invalid byteorder" but I 
> didn't find specific suggestions.

It's a tool bug but a fairly harmless one.


<Prev in Thread] Current Thread [Next in Thread>