[Top] [All Lists]

NFS Root broken in 2.4.18? Anyone successfully booted?

To: 'Ralf Baechle' <>, "TWEDE,ROGER (HP-Boise,ex1)" <>
Subject: NFS Root broken in 2.4.18? Anyone successfully booted?
From: "TWEDE,ROGER (HP-Boise,ex1)" <>
Date: Thu, 31 Oct 2002 13:28:05 -0500
Cc: "''" <>
Original-recipient: rfc822;
Ralf et al,

I found that the 2.4.18 system boots fine when booting from standard devices
(IDE disks etc.).

Init fails to execute successfully when booting from NFS.  The NFS booting
success appears to have died with 2.4.18.

The NFS boot completes fine in 2.4.17 but in 2.4.18 the NFS root is mounted
and /sbin/init and the are at least accessed, but the system never
executes far enough in user space to even print a message to the console.

I've tried two different network card types just to be sure it wasn't a
single driver issue.

Has anyone noticed this or does anyone know what changes may have caused
this in 2.4.18? 
I'm curious whether anyone has successfully booted 2.4.18 over NFS.


Roger Twede
Hewlett Packard

-----Original Message-----
From: Ralf Baechle []
Sent: Wednesday, October 30, 2002 8:06 AM
To: TWEDE,ROGER (HP-Boise,ex1)
Cc: ''
Subject: Re: Recent Kernel Page Fault Problems Spawning Init?

On Tue, Oct 29, 2002 at 05:53:15PM -0500, TWEDE,ROGER (HP-Boise,ex1) wrote:

> I would be appreciative of any advice anyone can offer in this regard.
> Were any fundamental kernel changes made in the 2.4.17 through 2.4.19
> timeframe which could explain why the spawning of init would hang?
> After mounting a root filesystem and attempting to spawn init, 3 or 4 page
> faults occur.  The entry point of init, its bss section and an elf loader
> .text section get hit, etc.  followed by an endless series of page faults
> a bad address which just faults repeatedly, never allowing init or the elf
> loader to proceed.
> I've tried a RM 7000A and 20KC based boards so far with apparently
> behavior on both.

Various people have reported this kind of problem in past but so far all of
them turned out some local problem.  20kc and RM7000 are both supposed to be
working fine.


<Prev in Thread] Current Thread [Next in Thread>