[Top] [All Lists]

cannot debug multi-threaded programs with gdb

To: Linux-MIPS <>
Subject: cannot debug multi-threaded programs with gdb
From: Stuart Hughes <>
Date: Fri, 13 Sep 2002 11:07:15 +0100
Organization: Zee2 Ltd
Original-recipient: rfc822;

I've been trying to debug a simple multi-threaded test program using
gdb, and it always fails as follows:

[New Thread 1024 (LWP
Program received signal SIGTRAP, Trace/breakpoint
[Switching to Thread 1024 (LWP
warning: Warning: GDB can't find the start of the function at

I've tried various different compilers, gdb, glibc version but the
problem is the same.  Note that I can debug non-threaded c/c++ programs
without any problem.  My environment is as follows:

CPU:            NEC VR5432
kernel:         linux-2.4.10 + patches
glibc:          2.2.3 + patches
gdb:            5.2/3 from CVS
gcc:            3.1 (also tried 3.0.1)
binutils:       Version

Does anyone have any idea what is wrong and how to fix it. 

Regards, Stuart

<Prev in Thread] Current Thread [Next in Thread>