[Top] [All Lists]

Re: xfs

To: "Pete Popov" <>, "Martin K. Petersen" <>
Subject: Re: xfs
From: "Liam Davies" <>
Date: Mon, 11 Mar 2002 09:04:09 +1000
Cc: "linux-mips" <>
Organization: AgileTV Corporation
References: <1015611727.12994.441.camel@zeus> <> <1015632468.6456.24.camel@zeus>
Reply-to: "Liam Davies" <>

> I took 1.0.2 patch and applied it against the latest linux_2_4 oss
> kernel.
I tried the same against 2.4.14, but had the same problems you
described below. I then tried the split-only and split-kernel patches from
2.4.14 XFS cvs snapshot, taken just before or after 1.0.2 release - no
changes required. Everything seems to be working dandy.

> I cross compiled the kernel with 2.95.3 based tools (I know the older
> toolchain is recommended but ...).  xfsprogs I compiled natively with
> the same version tools.
I haven't tried any compilers earlier that gcc 3.0, but 3.0.1 and 3.0.3
have both worked for me.

> The kernel boots and I was able to create an
> XFS file system on one of the partitions.  Mounting works. Unmounting
> consistently results in a crash, illegal access to location 0x00000018.
> It's probably easy to fix since it's 100% reproducible.  Back to
> mounting the fs -- I ran bonnie++ on it. It ran for quite a while until
> it got to the "sequential" write test and then the kernel froze.
I had both of these symptoms after applying the 1.0.2 patch in its
entirety.  After switching to split-kernel and split-only patches only
these things went away. I didn't delve any deeper.


Agile Tv

<Prev in Thread] Current Thread [Next in Thread>