[Top] [All Lists]

Re: madplay on mips

To: Jun Sun <>
Subject: Re: madplay on mips
From: Pete Popov <>
Date: 04 Feb 2002 10:46:54 -0800
Cc: linux-mips <>
In-reply-to: <>
References: <1012843753.14993.106.camel@zeus> <>
On Mon, 2002-02-04 at 10:42, Jun Sun wrote:
> Pete Popov wrote:
> > 
> > Has anyone used madplay on mips to play mp3 files successfully? I've
> > tried it on two mips boards with different sound drivers, and in both
> > cases it plays the song slower and a bit muffled.  It works on x86 and
> > supposedly ppc.
> > 
> I tried it before, and had the same results.
> I looked over the system calls, and was pretty much sure that the problem was
> on madplay side, and not on the driver side.  One problem suspected was the
> floating point issue, but did get into it.

Even though madplay claims that no floating point is used, the
disassembly of the latest version shows otherwise. But I tried it on a
board with a cpu that does have a hardware floating point unit with the
same result.


<Prev in Thread] Current Thread [Next in Thread>