[Top] [All Lists]

Re: LTP tests / Crash :)

To: Zhang Fuxin <>
Subject: Re: LTP tests / Crash :)
From: Florian Lohoff <>
Date: Fri, 11 Jan 2002 02:55:55 +0100
Cc: "linux-mips @ oss. sgi. com" <>
In-reply-to: <>
Organization: rfc822 - pure communication
References: <>
User-agent: Mutt/1.3.25i
On Fri, Jan 11, 2002 at 08:58:15AM +0800, Zhang Fuxin wrote:
> hi,Florian Lohoff??

Flo shortform :)

>  i have noticed that a while ago and send ralf and fix,he
> make his own fix in current cvs.

The current cvs is stable for me :)

>  My ltp runs turns out a number of failures,the one worry me
> most are the filesystem corrupts(mmap write?),but i had no time
> to follow them currently.

Havent seen those yet - This sounds like cache issues or probably
disk controller stuff - I am not running plain cvs - I am running
with some r4k cache wback/inv modifications i tried in connection
with my sgiwd93.c cleanup/fix.

Most annoying i guess is the still not perfect fpu emulation which
also causes the "sleep" bug where sleeps sometime return after 22 years
(strace output) as there are fpu problems within librt 

And at least i know of one real-world app which had problems with 
message passing/shared memory - The Xfree server garbles xbitmaps
within the server in shared segments - The happens with Gnome on
XFree 4 on the Indy.

shmat01     2  FAIL  :  shared memory address is not correct
shmdt02     1  FAIL  :  call succeeded unexpectedly

These are also interesting:

fcntl05     1  BROK  :  Unexpected signal 15 received.
pipe05      1  BROK  :  Unexpected signal 11 received.
sched_getscheduler01    1  BROK  :  Unexpected signal 11 received.

Florian Lohoff                     +49-5201-669912
Nine nineth on september the 9th              Welcome to the new billenium

Attachment: pgptYHx4IIFe9.pgp
Description: PGP signature

<Prev in Thread] Current Thread [Next in Thread>