[Top] [All Lists]

Inclusion of rrm.o in export-objs

To: <>
Subject: Inclusion of rrm.o in export-objs
From: "Ivan Hamilton" <>
Date: Fri, 16 Nov 2001 00:38:46 +1100
Thread-index: AcFt2tMZ4AsjtqC4SJuT59472mrXSg==
Thread-topic: Inclusion of rrm.o in export-objs
I'm a little new, so let me know if this is out of place.

After grabbing the latest source via CVS, I ran into compilation
A little (read "a lot of") searching, and I found I was not alone with
this problem.
This fix, worked for me. But I'm not sure why no one else had run into

My Makefile knowledge is extremely limited to say the least. But are
there possible side-effects of this particular fix? And how does a fix
like this, find it's way back into the source tree?

Any pointers, or other information welcome.


*       Newsgroups: linux.debian.ports.mips 
*       From: Petter Reinholdtsen <
*       Subject: Compile problem with latest mips kernel CVS 
*       Date: Wed, 07 Nov 2001 09:40:07 +0100 
*       Organization: linux.*_mail_to_news_unidirectional_gateway 
*       Approved: (1.20) 


I do not have post access to, so I try to send
it here instead.

I tested to compile the kernel from the mips kernel CVS last night,
and it stopped with the following error.  The error line is
"EXPORT_SYMBOL(<symbol>');".  The object rrm.o must be added to
export-objs.  Patch below.

make[4]: Entering directory `/usr/src/linux-cvs/drivers/sgi/char'

gcc -I /usr/src/linux-cvs/include/asm/gcc -D__KERNEL__
-I/usr/src/linux-cvs/include -Wall -Wstrict-prototypes -Wno-trigraphs
-O2 -fomit-frame-pointer -fno-strict-aliasing -fno-common -G 0
-mno-abicalls -fno-pic -mcpu=r4600 -mips2 -Wa,--trap -pipe -DMODULE
-mlong-calls   -c -o rrm.o rrm.c
Assembler messages:
Warning: The -mcpu option is deprecated.  Please use -march and -mtune
Warning: The -march option is incompatible to -mipsN and therefore
rrm.c:74: parse error before
rrm.c:74: warning: type defaults to `int' in declaration of
rrm.c:74: warning: data definition has no type or storage class
rrm.c:75: parse error before
rrm.c:75: warning: type defaults to `int' in declaration of
rrm.c:75: warning: data definition has no type or storage class
make[4]: *** [rrm.o] Error 1
make[4]: Leaving directory `/usr/src/linux-cvs/drivers/sgi/char'

 - Add rrm.o to export-objs, and sort the list of objects.

Index: Makefile
RCS file: /cvs/linux/drivers/sgi/char/Makefile,v
retrieving revision 1.13
diff -u -r1.13 Makefile
--- Makefile    2001/03/11 03:35:59     1.13
+++ Makefile    2001/11/07 08:27:35
@@ -9,7 +9,7 @@

 O_TARGET := sgichar.o

-export-objs    := newport.o shmiq.o sgicons.o usema.o
+export-objs    := newport.o rrm.o sgicons.o shmiq.o usema.o
 obj-y          := newport.o shmiq.o sgicons.o usema.o streamable.o

 obj-$(CONFIG_SGI_SERIAL)       += sgiserial.o

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact


<Prev in Thread] Current Thread [Next in Thread>