[Top] [All Lists]

Re: Backspace on Virtual Console causes oops

To: Wayne Gowcher <>
Subject: Re: Backspace on Virtual Console causes oops
From: "Gleb O. Raiko" <>
Date: Mon, 29 Oct 2001 11:26:48 +0300
Organization: NIISI RAN
References: <>
Wayne Gowcher wrote:
> Gleb,
> > Guess 1: You've got PC UARTs and
> > drivers/char/serial.c
> > Guess 2: TAB TAB in bash causes the oops too.
> > Guess 3: You didn't change famous beep function in
> > the driver.
> Correct on all 3 counts. Thanks for pointing the way.

In fact, guess 1 is irrelevant. :-)

> I am grateful that my problem was solved quickly. But
> before I posted to the list I did a search on
> "Backspace oops linux", "Backspace crash linux" and a
> few other combinations to see if this was possibly a
> known problem. But turned nothing up.
> Is there any other list / repository I should be
> looking at to pick up on bugs like this ?
> Any tips / info would be greatly appreciated.

This is a famous problem, just look at vt.c, you'll see a lot of ifdefs
around sound routines. Just every porting engineer who encounter this
problem solved it himself (and added own ifdef to vt.c). In my case, I
just got fault epc, found the address in objdump -D output and look at
the sources. For me it seems easier, than posting a message to a list.
<nothing personal, really>


<Prev in Thread] Current Thread [Next in Thread>