[Top] [All Lists]

native gcc-3.0.1?

Subject: native gcc-3.0.1?
From: Jim Paris <>
Date: Thu, 20 Sep 2001 01:57:42 -0400
User-agent: Mutt/1.2.5i
Does anyone have gcc-3.0.1 built as a native MIPS compiler?
I have a 3.0.1 cross-compiler that seems to work fine, but when I
cross-compiled a native gcc-3.0.1, it doesn't work:

# cat hello.c
    printf("hello, world\n");
# gcc -c hello.c
hello.c: In function 'main':
hello.c:4: Internal error: Illegal instruction
Please submit a full bug report
with preprocessed source if appropriate.
See <URL:> for instructions.

It's possible that

1) My kernel is broken.  I doubt this, only because the other
   possibilities seem more likely; I suppose I could add debugging
   output to all of the places where the kernel generates SIGILL
2) My cross-compiler is broken.  But, everything else it's compiled
   has worked fine, including relatively complicated programs like
   strace and bash.

It could also be that gcc-3.0.1 is simply broken when running natively
on MIPS.  Has anyone done this?  Any luck?

It's also possible (and I think likely) that my cross-compiler is
making wrong assumptions about the target system (since ./configure
can be pretty dumb when it comes to setting up a cross compile).  If
anyone has built gcc-3.0 or gcc-3.0.1 natively on MIPS, can you send
me the config.cache from your build?

I tried using my gcc-3.0.1 cross-compiler to build a native gcc-2.95.3
instead, but the newer GCCs doesn't seem to happy about building old
ones.  Grr..


<Prev in Thread] Current Thread [Next in Thread>