[Top] [All Lists]

Continued MIPS kernel debugging symbols problem...

Subject: Continued MIPS kernel debugging symbols problem...
From: "Steven J. Hill" <>
Date: Thu, 13 Sep 2001 21:34:18 -0500

I have tried everything I can to get Linux kernel debugging
symbols to work properly. I apologize for posting to so
many lists too, but I really need to get this working. I
traded a few emails with HJ Lu and he referred me to the
following messages/threads:

I did read them a few times and it appears that all the
necessary changes are in the current gdb and insight CVS
repositories. I checked out the latest sources a half
hour ago and compiled both gdb and insight using the
configuration line:

    configure --prefix=/opt/tools --target=mipsel-linux-elf

since my target is a NEC 5432 running in LE mode. I had
also tried 'mips-linux-elf' targets earlier in the day
with no difference. I am still getting the following
mismatch in symbols:

(gdb) target remote /dev/ttyS1
Remote debugging using /dev/ttyS1
0x80012828 in breakinst () at af_packet.c:1879
1879            sock_unregister(PF_PACKET);
(gdb) bt
#0  0x80012828 in breakinst () at af_packet.c:1879
#1  0x8001a0d4 in sys_create_module (name_user=0x10001dc8 "cfi_probe",
    size=8176) at module.c:305
(gdb) c

I compiled my kernel with a toolchain that used the following
versions of tools:

    binutils- (HJLu patches applied)
    gcc-3.0.1 (stock)
    glibc-2.2.3 (minor build patches)

Things are still not working and I would greatly appreciate some
direction. I've blown a whole day this and am a bit frazzled.
Thanks a bunch in advance.


 Steven J. Hill - Embedded SW Engineer

<Prev in Thread] Current Thread [Next in Thread>