[Top] [All Lists]

Re: NFS -13 error

To: Guido Guenther <>, <>
Subject: Re: NFS -13 error
From: "John D. Davis" <johnd@Stanford.EDU>
Date: Thu, 3 May 2001 17:15:59 -0700 (PDT)
In-reply-to: <>
I have downloaded the linux stuff and a kernel image(2.4.0-ip22) from the
site listed below.  I am getting a kernel panic.  I am nolonger getting
nfs errors. I added a link from /tftpboot/to the debian linux directory on
the server.  I guess dhcp_bootp doesn't have the right flag set or
something.  However, the message is:

>Kernel panic: I have no root and I want to scream.

Is there a flag that I need to set for the root? I have /etc/exports with
the -root=sgilinuxIPaddress,rw for the parent directory of the linux
distribution?  I have tried other vmlinux kernels and gotten the same type
of problem.  THe one from sgi says it can't mount fs and ask for root=.  I
have tried to set that at the bootp():vmlinux root=/linux but that did not
help either. Furthermore, I am not getting an mountd error on the SGI
server.  Any and all suggestions would be greatly appreciated.

I am trying to install linux from an SGI Indy running IRIX over the

john davis

On Wed, 2 May 2001, Guido Guenther wrote:

> On Tue, May 01, 2001 at 04:29:18PM -0700, John D. Davis wrote:
> >
> > I am having a problem installing linux on a 4400 indy.  I downloaded a
> > "fixed" version from: honk.physik.uni-konstanz,de/linux-mips/install
> > and downloaded :
> > root-be-0.04.cpio
> This one is *very* outdated. Don't use it. It's there for purely
> "historic reasons".
> See
> for an up to date root image.
>  -- Guido

<Prev in Thread] Current Thread [Next in Thread>