[Top] [All Lists]

Re: serial console, have linefeed but no command prompt

Subject: Re: serial console, have linefeed but no command prompt
From: Wayne Gowcher <>
Date: Wed, 25 Apr 2001 11:38:20 -0700 (PDT)
In-reply-to: <>
Pete, Scott,

Thanks for your input.

I tried booting with init=/bin/ash.static and with a
simple "hello world type app". None of them gave me
any output to the serial terminal. I also have console
defined as a boot param :

xxx console=ttyS0 xxx

I tried modifying my /etc/inittab as per Scott's
suggestion, but that also didn't give me any output.

my inittab was :


# Run gettys in standard runlevels
1:12345:respawn:/sbin/mingetty tty1
2:2345:respawn:/sbin/mingetty tty2
3:2345:respawn:/sbin/mingetty tty3
4:2345:respawn:/sbin/mingetty tty4
5:2345:respawn:/sbin/mingetty tty5
6:2345:respawn:/sbin/mingetty tty6


One further thing I tried was adding a printk( "a" );
in the serial interrupt handler, whenever I hit the
return key, it prints out the "a". So I know the
serial link still works and is at the correct baud
rate etc.

I can use gdb on the board to step through the code
and was thinking that if I knew the path of how the
kernel :

a, receives a key from the serial terminal
b, processes the key 
c, echoes it back to the serial trminal

I may be able to trace the problem. Does anyone know
roughly what functions to set breakpoints in to trace
program flow as shown above ?



Do You Yahoo!?
Yahoo! Auctions - buy the things you want at great prices

<Prev in Thread] Current Thread [Next in Thread>