[Top] [All Lists]

glibc 2.2.2 on linux mips kernel 2.2 NOGO

Subject: glibc 2.2.2 on linux mips kernel 2.2 NOGO
From: Florian Lohoff <>
Date: Mon, 12 Mar 2001 16:39:38 +0100
Cc: Andreas Jaeger <>
Organization: rfc822 - pure communication
User-agent: Mutt/1.2.5i
I tried building glibc 2.2.2 on Linux-mips (Kernel 2.2.16) with no success.
I was using Keiths cross stuff to determin the way it worked for him.

I am getting the following output.

./configure --prefix=/usr --with-headers=/usr/src/linux/include/
   --enable-kernel=2.2.15 --enable-add-ons --with-elf --disable-profile

Results in:

../elf/ --library-path 
 ./rpcgen -Y `gcc -print-file-name=cpp | sed 's|/cpp$||'` -c 
rpcsvc/bootparam_prot.x -o xbootparam_prot.T
make[1]: *** [xbootparam_prot.stmp] Segmentation fault

The same happens when i remove the "--enable-kernel=2.2.15" completely. In
case i am using an "--enable-kernel=2.3.99" i am getting


I was using

flo@repeat:~/glibc-2.2.2$ gcc -v
Reading specs from 
Configured with: ./configure --prefix=/home/flo/gcc-3.0 --with-newlib 
--disable-shared --enable-languages=c
gcc version 3.0 20010303 (prerelease)
flo@repeat:~/glibc-2.2.2$ ld -v
GNU ld version 2.11.90 (with BFD 2.11.90)
flo@repeat:~/glibc-2.2.2$ head /usr/src/linux/include/linux/version.h 
#define UTS_RELEASE "2.4.2"
#define LINUX_VERSION_CODE 132098
#define KERNEL_VERSION(a,b,c) (((a) << 16) + ((b) << 8) + (c))
flo@repeat:~/glibc-2.2.2$ uname -a
Linux 2.2.16 #42 Fri Dec 29 11:46:41 CET 2000 mips unknown

Florian Lohoff                     +49-5201-669912
     Why is it called "common sense" when nobody seems to have any?

<Prev in Thread] Current Thread [Next in Thread>
  • glibc 2.2.2 on linux mips kernel 2.2 NOGO, Florian Lohoff <=