[Top] [All Lists]

Re: Patch Problems with Glibc 2.2

To: Ian Chilton <>
Subject: Re: Patch Problems with Glibc 2.2
From: "Maciej W. Rozycki" <>
Date: Mon, 13 Nov 2000 18:53:20 +0100 (MET)
In-reply-to: <>
Organization: Technical University of Gdansk
On Sun, 5 Nov 2000, Ian Chilton wrote:

> I am having a problem with patch under glibc 2.2
> patch: **** Only garbage was found in the patch input.
> If I exit my chroot, back to my 2.0.6 base and use the same source dir, with 
> the same patch there, it works fine, so it is definatly the patch program.
> It was compiled exactly the same way as the 2.0.6 based base too. Tried 
> re-compiling, and still the same..
> Everything else so far seems to work under my 2.2 base, incl compiler etc..

 This is due to the LFS support that's present in glibc 2.2 (fseeko() is
the reason of the trouble here).  Get a patch source RPM package from my
FTP site ( for a fix.  An alternative
solution is available in the current CVS version of patch, I am told.

+  Maciej W. Rozycki, Technical University of Gdansk, Poland   +
+        e-mail:, PGP key available        +

<Prev in Thread] Current Thread [Next in Thread>