[Top] [All Lists]

Re: GCC Problem

Subject: Re: GCC Problem
From: Keith M Wesolowski <>
Date: Mon, 30 Oct 2000 07:08:46 -0800
In-reply-to: <>; from on Mon, Oct 30, 2000 at 11:50:10AM +0000
References: <>
User-agent: Mutt/1.2i
On Mon, Oct 30, 2000 at 11:50:10AM +0000, Ian Chilton wrote:

> I had a problem compiling egcs 1.0.3a nativly. I had it a few weeks
> ago, and fixed it, and it worked. Now, I am having exactly the same
> problem again, and I can't seem to fix it...annoying..

> /lfstmp/egcs-1.0.3a/gcc-build/gcc/xgcc
> -B/lfstmp/egcs-1.0.3a/gcc-build/gcc/ -g -O2 -fno-implicit-templates
> -EL -Wl,-soname,`echo 2.8.0 | sed
> 's/\([0-9][.][0-9]\).*/\1/'` -shared -o `cat
> piclist` -lm /usr/lib/ could not read symbols: Invalid
> operation collect2: ld returned 1 exit status make[4]: ***
> [] Error 1

I used to get this too; I think it's simply a bug in old egcs. It
tries to multilib libstdc++, which is usually impossible, since you
would need to have both big and little endian in the same
place. Since you don't need little-endian (or big-endian, if building
mipsel) libstdc++ anyway, and the big endian one has already been
built, the error is ignorable.

Keith M Wesolowski            
University of Nevada          
Chemistry Department Systems and Network Administrator

<Prev in Thread] Current Thread [Next in Thread>
  • GCC Problem, Ian Chilton
    • Re: GCC Problem, Keith M Wesolowski <=