[Top] [All Lists]

Re: Still cannot compile the KERNEL!!!

To: Nicu Popovici <>
Subject: Re: Still cannot compile the KERNEL!!!
From: Florian Lohoff <>
Date: Mon, 30 Oct 2000 15:21:29 +0100
In-reply-to: <>; from on Mon, Oct 30, 2000 at 12:21:38PM -0500
Organization: rfc822 - pure communication
References: <>
User-agent: Mutt/1.0.1i
On Mon, Oct 30, 2000 at 12:21:38PM -0500, Nicu Popovici wrote:
> Hello you all,
> I have a problem. I've built a crosscompiler for MIPS on my intel
> machine but until now I could not compile any mips kernel. I tried with
> version from CVS site  and now I an trying with
> linux-2.2.12.mips-src.01.04.tar.gz and I an running into errors from the
> beggining.( are in the attached file )
> I still succeded to compile a test.c file on my intel machine with my
> crosscompiler and then to run the resulted file on the mips machine and
> it worked.
> When I tried with the g++ and with the test.cpp ( a simple class ) the
> crosscompiler made a file but when I executed on the mips machine it
> says
> a.out error in loading shared libraries
> undefined simbol : _deregister_frame_info

I guess you have a broken 2.07 glibc for mips lying around - Try to eliminate
that and use the 2.06 made by ralf or start with glibc 2.2
(For experienced users)

BTW: For compiling a kernel you dont need and glibc on the cross devel machine
at all.

Florian Lohoff                     +49-5201-669912
     Why is it called "common sense" when nobody seems to have any?

<Prev in Thread] Current Thread [Next in Thread>