[Top] [All Lists]

GCC Problem

Subject: GCC Problem
From: Ian Chilton <>
Date: Mon, 30 Oct 2000 11:50:10 +0000
Fcc: /var/mail/sent-mail-oct2000
User-agent: Mutt/1.3.9i

I had a problem compiling egcs 1.0.3a nativly. I had it a few weeks ago, and 
fixed it, and it worked. Now, I am having exactly the same problem again, and I 
can't seem to fix it...annoying..

The system has glibc-2.0.6-7lm and binutils-2.8.1. I am using the egcs-1.0.3a-3 
Last time I did it, I was using -5lm and the egcs -2 patch..

Here is the problem:

/lfstmp/egcs-1.0.3a/gcc-build/gcc/xgcc -B/lfstmp/egcs-1.0.3a/gcc-build/gcc/ -g 
-O2 -fno-implicit-templates  -EL -Wl,-soname,`echo 2.8.0 | sed 
's/\([0-9][.][0-9]\).*/\1/'` -shared -o `cat piclist` -lm
/usr/lib/ could not read symbols: Invalid operation
collect2: ld returned 1 exit status
make[4]: *** [] Error 1
make[4]: Leaving directory 
make[3]: *** [multi-do] Error 1
make[3]: Leaving directory `/lfstmp/egcs-1.0.3a/gcc-build/libraries/libstdc++'
make[2]: *** [multi-all] Error 2
make[2]: Leaving directory `/lfstmp/egcs-1.0.3a/gcc-build/libraries/libstdc++'
make[1]: *** [all-target-libstdc++] Error 2
make[1]: Leaving directory `/lfstmp/egcs-1.0.3a/gcc-build'
make: *** [bootstrap] Error 2

I seem to remember the fix was something like creating symlinks. In /usr/lib, I 
only had libstdc++.a, so I copied from my working /usr/lib 
dir and made some symlinks as below:

bash-2.04# ls -l /usr/lib/libstdc*
-rw-r--r--   1 root     root      1852098 Oct 28 20:28 /usr/lib/libstdc++.a
lrwxrwxrwx   1 root     root           18 Oct 29 15:40 /usr/lib/ ->
lrwxrwxrwx   1 root     root           18 Oct 29 15:40 
/usr/lib/ ->
-r-xr-xr-x   1 root     root       510594 Oct 29 12:53 

I also seem to have all of these OK:

bash-2.04# ls -l /usr/lib/libm*
-rw-r--r--   1 root     root      1240434 Oct 29 15:29 /usr/lib/libm.a
lrwxrwxrwx   1 root     root           19 Oct 29 15:29 /usr/lib/ -> 
-rw-r--r--   1 root     root      1255528 Oct 29 15:29 /usr/lib/libm_p.a
-rw-r--r--   1 root     root         3764 Oct 29 15:29 /usr/lib/libmcheck.a

bash-2.04# /sbin/ldconfig

Can someone help me out here, bcause I have had it working, and know it works, 
but it is frustrating  :)

Just to let you know what I am working on....I hope to have a glibc-2.0.6/egcs 
1.0.3a/2.2.14 system AND a glibc-2.2/new gcc/2.4pre9 system available for 
download in the next week or 2....


Bye for Now,


                     (o o)
 |  Ian Chilton                              |
 |  E-Mail :              |

<Prev in Thread] Current Thread [Next in Thread>