[Top] [All Lists]

Still cannot compile the KERNEL!!!

Subject: Still cannot compile the KERNEL!!!
From: Nicu Popovici <>
Date: Mon, 30 Oct 2000 12:21:38 -0500
Hello you all,

I have a problem. I've built a crosscompiler for MIPS on my intel
machine but until now I could not compile any mips kernel. I tried with
version from CVS site  and now I an trying with
linux-2.2.12.mips-src.01.04.tar.gz and I an running into errors from the
beggining.( are in the attached file )

I still succeded to compile a test.c file on my intel machine with my
crosscompiler and then to run the resulted file on the mips machine and
it worked.
When I tried with the g++ and with the test.cpp ( a simple class ) the
crosscompiler made a file but when I executed on the mips machine it
a.out error in loading shared libraries
undefined simbol : _deregister_frame_info

I hope that anyone will help me on that . I am running out of time .

n file included from /usr/src/atlas_linux/include/linux/timex.h:138,
                 from /usr/src/atlas_linux/include/linux/sched.h:14,
     from /usr/src/atlas_linux/include/linux/proc_fs.h:5,
                      from init/main.c:23:
                      /usr/src/atlas_linux/include/asm/timex.h:36: warning: 
implicit declaration of function `read_32bit_cp0_register'
                      /usr/src/atlas_linux/include/asm/timex.h:36: `CP0_COUNT' 
undeclared (first use this function)
                      /usr/src/atlas_linux/include/asm/timex.h:36: (Each 
undeclared identifier is reported only once
                      /usr/src/atlas_linux/include/asm/timex.h:36: for each 
function it appears in.)
                      make: *** [init/main.o] Error 1

Attachment: octavp.vcf
Description: Card for Nicu Popovici

<Prev in Thread] Current Thread [Next in Thread>