[Top] [All Lists]

Re: Threads on mips

To: Mark Lehrer <>
Subject: Re: Threads on mips
From: Jun Sun <>
Date: Thu, 26 Oct 2000 14:17:53 -0700
References: <>
Mark Lehrer wrote:
> Hello!  I am just getting started with one of the MIPS embedded
> platforms, the NEC VR4122.  I downloaded the kernel & ramdisk from the
> linux-vr web pages.
> Some of the apps I'm trying to port over use pthreads; however, the
> pthread library that is included doesn't appear to work - the process
> that tries to create a thread just waits forever until I hit ctrl-c.

I have worked with linux-vr before and tried to get pthread working. 
The glibc v2.0.7 had several problems in terms of getting pthread

> Is anyone using threads with the mips embedded platforms?  If so, what
> kernel, libc, and pthreads library are you using?

I just found a bug in kernel yesterday.  After the temporary fix, my
pthread test program seems to work.  I am using glibc 2.0.6.  Kernel is
v2.4 from cvs tree.
> If not, has anyone thought about what it might take to get threads to
> work?

I am thinking about that a lot. :-)  I like to get ViewML, a web
broswer, working.  It requires pthreads.


<Prev in Thread] Current Thread [Next in Thread>