[Top] [All Lists]

Re: pthread_create() gets BUS ERROR

To: Ralf Baechle <>
Subject: Re: pthread_create() gets BUS ERROR
From: Jun Sun <>
Date: Tue, 24 Oct 2000 14:36:22 -0700
References: <> <> <> <>
Ralf Baechle wrote:
> On Mon, Oct 23, 2000 at 06:24:18PM -0700, Jun Sun wrote:
> > Since Ralf has not posted his patch for glibc yet, I looked into the
> > problem a little bit more.
> If you'd be waiting just a few minutes longer I'd have announced it :-)
> The srpm is currently uploading to
> srpms/glibc-2.0.6-7lm.src.rpm.  The file is 4682466 bytes long, so don't
> start downloading before it's completly uploaded :-)
> > It appears to be another toolchain related problem, instead of a glibc
> > problem.
> >
> > In linuxthread/pthread.c:pthread_initialize_manager(), it accesses a
> > global variable __pthread_initial_thread_bos in pthread shared library.
> > Apparently the code finds out the address of the variable through some
> > table (why is that?).  It looks like the offset for variable is off by
> > 8.  Another ld problem?
> >
> > I am using the "old but stable" toolchains, as I stated in an earlier
> > email.:-9
> This description somehow rings a bell.  I'll dig through my mailfolders
> and will post if I find something.
>   Ralf

Since I suspect it is binutils problem, I tried to use the latest
binutil with egcs 1.0.3a and glibc 2.0.6.  This leads to unusable
userland programs - init hangs.  sash runs, but nothing else seems to
work.  Do that mean I should not mix up the versions among toolchains? 
Has anybody tried that above combo before?

I will try glibc-2.0.6-7lm.src.rpm, but I am very hopeful that it will
solve this problem.

BTW, has anybody got pthread running on any 2.4 Linux/MIPS?  I want to
know if I am just unlucky or else...


<Prev in Thread] Current Thread [Next in Thread>