[Top] [All Lists]

Re: [Install trouble] : mount failed: bad address

To: Nathan Fraser <>
Subject: Re: [Install trouble] : mount failed: bad address
From: Keith M Wesolowski <>
Date: Mon, 7 Aug 2000 08:30:02 -0700
In-reply-to: <>; from on Mon, Aug 07, 2000 at 10:27:03PM +1000
References: <>
User-agent: Mutt/1.2i
On Mon, Aug 07, 2000 at 10:27:03PM +1000, Nathan Fraser wrote:

> I just tried installing with vmlinux-000804-IP22-4400 and
> hardhat-sgi-5.1.tar.gz - i get the same error as soon as the drive is
> formatted and is mounted (ie: mount failed: bad address)

I wonder if the DeadRat installer is using peecee style partition
tables. If so, then this is probably the source of the trouble. The
kernels I build, as you can see from the .config, don't support those,
only SGI style disklabels. If the fdisk in the installer doesn't
support that, then it won't work. It does seem odd though that you
couldn't mount an existing EFS filesystem.

There are also several problems with older fdisks; indeed, I think you
still need one of my patches for the current one to work properly.

The dated kernels I'm posting there are CVS from the 2.3/2.4 tree,
built with a CVS compiler and binutils. I wouldn't go using those on a
lark. For something as old as Hard Hat, maybe try the 2.2 kernel

I must admit to being the one person on this list who has never even
attempted to install Hard Hat, though, so maybe I don't know what I'm
talking about. :)

Keith M Wesolowski            
University of Nevada          
Chemistry Department Systems and Network Administrator

<Prev in Thread] Current Thread [Next in Thread>