[Top] [All Lists]

Re: C/Assembler question

To: Jeff Harrell <>
Subject: Re: C/Assembler question
From: Ralf Baechle <>
Date: Fri, 7 Jan 2000 23:41:39 +0100
In-reply-to: <>
References: <>
On Fri, Jan 07, 2000 at 09:23:13AM -0700, Jeff Harrell wrote:

> I seem to be having problems with the compiler in getting a  c/assembly
> listing.  I have tried a couple sets of the tools and seem to be
> getting the same error with both sets.  Is my syntax correct on the line
> below?  Its the -Wa,-a=pc_keyb.lst that seems to cause the
> problem.
> mips-linux-gcc -D__KERNEL__ -I/home/jharrell/work/mips_linux/include -g
> -Wa,-a=pc_keyb.lst -Wall -Wstrict-prototypes -Wa,-a -O2
> -fomit-frame-pointer  -G 0 -mno-abicalls -fno-pic -mcpu=r4600 -mips3
> -pipe   -c -o pc_keyb.o pc_keyb.c
> This is the error that I get when I attempt it:
> pc_keyb.c: In function `kb_wait':
> pc_keyb.c:103: warning: unused variable `status'
> {standard input}: Assembler messages:
> {standard input}:565: Fatal error: Symbol kb_wait already defined.
> Is there a formatting problem with this command?  Any help would be
> greatly appreciated.

This is weird.  You pass an extra option to the assembler and the
compiler begins to spit errors?  Try adding -v as well and check gcc
actually passes down to cpp / cc1 / as, maybe that explains things.


<Prev in Thread] Current Thread [Next in Thread>