[Top] [All Lists]

SCSI problem nearly solved

Subject: SCSI problem nearly solved
From: Thomas Bogendoerfer <>
Date: Sun, 28 Mar 1999 17:49:12 +0200
Ok, after letting the problem get some rest I figured out why I see those
strange IRQ 0. There is a bug in the driver, which leads to enabling IRQ 0
instead of IRQ 1, when a scsi_abort() occurs. Easy fix, but only part of
the problem. The lockup happened because of a bug in the generic wd33c93
driver part. If the command, which should be aborted, was at the head
of the input queue, the driver messed up the input queue, which leads
to a endless loop on the next abort. Solved !

Now the only remaining problem is, that the the wd93 reset code, isn't
able to reset the bus, because the chip is busy (looks like it doesn't
get ready again in that situation). I guess I have to use the HPC3 channel
reset, but my first try to do it wasn't quite successful. I guess one
of my next tries will succeed:-)


   This device has completely bogus header. Compaq scores again :-|
It's a host bridge, but it should be called ghost bridge instead ;^)
                                        [Martin `MJ' Mares on linux-kernel]

<Prev in Thread] Current Thread [Next in Thread>
  • SCSI problem nearly solved, Thomas Bogendoerfer <=