[Top] [All Lists]

Re: Linux/Mips installation

To: Thomas Bogendoerfer <>
Subject: Re: Linux/Mips installation
From: Jake Griesbach <>
Date: Wed, 10 Mar 1999 16:02:08 -0700 (MST)
In-reply-to: <>
Reply-to: Jake Griesbach <>
That was it!  I removed the CDROM and internal floptical drive, and the
installation proceeded.  However, now I get the prom error when rebooting
that is caused by elf kernels on old proms:

Cannot load bootp()/vmlinux
Illegal f_magic number 0x7f45, expected MIPSELMAGIC or MIPSEBMAGIC.

I tried downloading the ecoff kernel you posted in the test directory, but
I still get the error.  Maybe I haven't installed it correctly, or maybe I
am not typing the correct boot command.

I have unzipped the ecoff kernel and placed it in the installation (remote
computer's) root directory.  (It does boot over NFS into the installation
script.)  I have verified the kernel installed on the local drive after
installation is the same size.  (I simply copied it over to the local
drive.)  Do I have to run something equivalent to lilo??

When rebooting I'm typing:  boot dksc(0,3)

3 is the SCSI id for the local installed drive.


Jake Griesbach

On Wed, 10 Mar 1999, Thomas Bogendoerfer wrote:

> On Tue, Mar 09, 1999 at 03:43:23PM -0700, Jake Griesbach wrote:
> > On Tue, 9 Mar 1999, Thomas Bogendoerfer wrote:
> > > please mail me the oops, so I could look up, where is happens.
> > 
> > Here it is:
> thanks. The oops is caused by something going wrong in the SCSI driver.
> I saw in your hinv, that there are different devices on your scsi bus.
> Could you please try to remove as much as possible from the bus and
> try it again ? What devices do have on the bus ?
> Thomas.
> -- 
>    This device has completely bogus header. Compaq scores again :-|
> It's a host bridge, but it should be called ghost bridge instead ;^)
>                                         [Martin `MJ' Mares on linux-kernel]

<Prev in Thread] Current Thread [Next in Thread>