[Top] [All Lists]

Re: efs fs module

To: Chad Streck <>
Subject: Re: efs fs module
From: Mike Shaver <>
Date: Thu, 04 Feb 1999 09:39:29 -0500
Cc: Linux SGI <>
Organization: Just Another Snake Cult
References: <>
Chad Streck wrote:
> I tried this questions to some people, but I was suggested to post here.

I think I was one of those people; sorry for not responding earlier. 
(Insert generic whiny excuse about travelling and mail backlog and

The state of the EFS code in the linus CVS tree is this:
- prior to the most recent kernel merge (to 2.1.131), the code in fs/efs
was able to mount and read EFS partitions, provided that they did not
involve indirect extents.  Symlinks and stuff all worked, although
building as a module did not.
- once I merged to 2.1.131 (and then checked in the EFS code), I started
to see very odd behaviour; specifically, the inode-mode checks for
directory/file/socket/etc. were failing in ``impossible'' ways.  I can
post more about that later, but if you've got an EFS partition handy,
just build with -DDEBUG_EFS and try to mount it.  You'll see the error
message in question.  On the bright side, module-loading works well.
- I have efslook code here as well, and was in the process of comparing
its indirect-extent algorithm to my own when I did the 2.1.131 merge of
my code, so maybe once I get past that inode-mode problem I can finish
it up?  Oh, to dream.

Hope that helps answer your question.


243311.90 206264.81

<Prev in Thread] Current Thread [Next in Thread>