[Top] [All Lists]

Re: 5.1 installation fun & games...

To: Shrijeet Mukherjee <>
Subject: Re: 5.1 installation fun & games...
From: Leon Verrall <>
Date: Mon, 13 Jul 1998 17:27:17 +0100 (BST)
Cc: SGI Linux <>
In-reply-to: <>
On Thu, 9 Jul 1998, Shrijeet Mukherjee wrote:

> ->Ah, a chicken and egg thing. You can nfsroot an SG linux box as long as you
> ->have a linux box to do it from...
> so do I understand correctly that I cannot boot my Indy for setting linux
> up from another IRIX box (running 6.5) ... but have to go find a Intel box
> running Linux ?

Well, here's a funny thing... 

I now have a debian Linux box in the office configured for bootp and tftp
etc. It has the manhattan alpha 1 distribution on it. I bootp():/vmlinuz my
Indy, the kernel boots fine and then:

  Warning: unable to open an initial console. 

Where have we seen this before? 

/etc/exports has :


I've tried mucking about with permissions on the files in
/usr/src/sgi/installfs/dev but no dice. And the code it stops at is:

  if (open("/dev/console", O_RDWR, 0) < 0)
                printk("Warning: unable to open an initial console.\n");

So nothing complicated happening there. It just plain can't open
/dev/console for read and write... rpc.mountd's debug output doesn't help.
It just says the mount was sucessful. 

I've also tried a few options like nfsroot=/usr/src/sgi/installfs,flags=dev
just to make sure...

Anyone else hitting this? 


Leon Verrall - 01189 307734  \ "Don't cut your losses too soon,
Secondline Software Support  / 'cos you'll only be cutting your throat.
Silicon Graphics, Forum 1,   \ And answer a call while you still care at all
Station Rd., Theale, RG7 4RA / 'cos nobody will if you wont" (6:00 - DT)

<Prev in Thread] Current Thread [Next in Thread>