[Top] [All Lists]

Step by step of my experience

Subject: Step by step of my experience
From: Emmanuel Mogenet <>
Date: Wed, 22 Oct 1997 15:26:58 -0700
Organization: Nothing Real, LLC
Hi guys,

I've tried to boot Linux on my old clunky R5k this morning, and
I thought I'd share the step by step with the list.

Basically, I've tried to boot off an EFS filesystem (d4), and here's
how I went about it:

1. /d4 is my third scsi disk, with EFS (/dev/sdc under linux)

2. My irix kernel is in /unix on first disk (/dev/sda), which is XFS.
   Which is OK, since only the kernel is on XFS and the loader can
   handle it.

3. mkdir /d4/lsgi

4. Put in

5. Put in

6. Extract root-be-0.00.cpio.gz in /d4:
        cd /d4
        gzip -dc lsgi/root-be-0.00.cpio.gz | cpio -icvd

7. Install kernel on /
        cd /d4/lsgi
        gzip -d vmlinux-970916-efs.gz
        cp vmlinux-970916-efs /vmlinux

8. Reboot, go to maintenance mode, launch sash and type:
        scsi(0)disk(1)rdisk(0)partition(0)/vmlinux root=/dev/sdc1

7. The kernel booted, said a great many (good) things and froze with the
   following messages:
        VFS: mounted root (efs filesystem) readonly
        EFS: inode 0x30301 has >EFS_MAX_EXTENTS (43)
        EFS: <6> attempt to access beyond end of device
        08:21 rw=0 want=1190802192, limit=4191574

Conclusion: Wait for Ralf to finish the EFS driver !
This is the exact bug he was talking about.

Also: I read a few mails about typing, under sash, the following:
        boot /vmlinux root=/dev/sdc1

Well, it doesn't work.
First, the syntax for the sash boot command in my PROM is: boot -f
<file> -n <args>
Second, when I did boot -f /vmlinux -n root=/dev/sdc1, it just loaded
the kernel,
but didn't jump into it. It just told me: the entry address is <some hex

When I did go <some hex number>, it ran linux, but tried to boot off 
Obviously it ignored the args.

I'm just wondering: is there many different versions of sash out there ?

I'm off trying to boot off tftpd.
I'll keep the list posted.


        - Mgix


Emmanuel Mogenet <>                       PGP Key on

<Prev in Thread] Current Thread [Next in Thread>