[Top] [All Lists]

Re: FP emulation patch available

To: "Kevin D. Kissell" <>
Subject: Re: FP emulation patch available
From: Harald Koerfgen <>
Date: Wed, 08 Mar 2000 19:43:39 +0100 (MET)
Cc: Linux SGI <>,,
In-reply-to: <025701bf88e2$c648a7e0$>
Organization: none
Reply-to: "Harald Koerfgen" <>
Hi Kevin,

On 08-Mar-00 Kevin D. Kissell wrote:
> Anyway, the my CPU detection would certainly not have worked for
> a Mobilon.   But it ought to have worked for a DECstation.  What
> CPU does it have?   In addition to the cpu_probe() routine itself,
> arch/mips/kernel/cpu_probe.c contains a table that describes the
> CPU's that are recognized, and in principle it "knows" all the CPUs
> that were recognized by the old assembler code in head.S, plus
> a couple more (R4300 and MIPS 4Kc/5Kc).   The problem may
> be a CPU that is mis-identified, or it may be that the options in the
> table associated with that CPU are incorrectly defined.  Please
> let me know what CPU and "PrID" the system has.

Been there, done that. It was just a missing case statement that got lost during
the merge :-)

For the records (Sharp Mobilon HC-4500):

Philips PR31700 (identical to Toshiba TMPR3912) @ 73.7 MHz, Implementation 0x22
(same as R46[45]0), Revision 0x10 (does anybody know what R46[45]0 have?).

Based on an R300A core with some ISA-II extensions, 1KB instruction cache, and
4KB write-through data cache, 32 TLB entries.

Back on topic:

My Mobilon dies horribly with the screen going blank and even a soft reset
doesn't revive it. All that helps is to remove all batteries. No error messages
can be seen.

My DS 5000/133 (R3000A) with FPU disabled and FPU emulation shows:
 Illegal instruction 00000034 at 801ce924, ... shows:
 801ce920 b dsemul_insns
 801ce928 b dsemul_cpc

Looks like your trick in mips_dsemul() doesn't work too well for ISA-I CPUs. Do
you have an idea for an alternative?


<Prev in Thread] Current Thread [Next in Thread>