[Top] [All Lists]

Question concerning memory initialization (4M->64M)

To: sgi-mips <>, linux-mips <>, linux-mips <>
Subject: Question concerning memory initialization (4M->64M)
From: Jeff Harrell <>
Date: Wed, 09 Feb 2000 13:35:58 -0700
I have run into an interesting problem and would like to run it past this newsgroup
to see if anyone has any experience in these areas.  I am running kernel 2.3.22 and
have upgraded my memory space from ~4M (0x400000) to ~64M (0x4000000).  I run the 4M
version of the kernel and have no problems but when I run the 64M version, I run
into problems during the mem_init() portion of the code.  Specifically during the
free_page(tmp) call during the determination of totalram, codepages and datapages.
It looks like it is failing during the call to remove_mem_queue() within free_pages_ok().
I am seeing the next->prev and prev->next  set to 0 causing a page fault.   Is there
anything that anyone is aware of that I would need to change (beyond mips_memory_upper)
that would enable me to increase available memory to 64M.  Any insights would be greatly appreciated.


Additional information:

high memory: 0x83fff000  start memory: 0x80433000

Jeff Harrell                    Work:  (801) 619-6104 
Broadband Access group/TI


<Prev in Thread] Current Thread [Next in Thread>