[Top] [All Lists]

5000/150 problem ...

Subject: 5000/150 problem ...
From: Michael Engel <>
Date: Sat, 29 May 1999 01:31:45 +0200 (MET DST)
In-reply-to: <> from "Houten K.H.C. van" at May 28, 99 07:42:11 pm

> Harald Koerfgen writes:
> >On 25-May-99 Karel van Houten wrote:
> >> My 260 boots fine from disk, using the NetBSD 1.0 bootloaders. So now
> >> I tried this on a 240 (with a buggy prom that doesn't tftpboot), and
> >> it just hang. I used the same kernel source / config as on my 260,
> >
> >Strange, exactly the same as your /260 before my patch, isn't it?

Whats that patch exactly ?

> >My first guess would be that not only tftp booting but also the
> >rex_clearcache callback is broken. I'll see if I can hack something
> >together.
> I just got a 5000/150 to test it. This system has some hardware failure
> that it doesn't RECEIVE anything from the network (PROM, NetBSD, Linux).

Hmmm, funny. I can't get my 5000/150 to work correctly with any kernel I
tried. It always hangs after the "This is a DECstation 5000/1xx" message.
I configured the kernel for R4000, of course (and the -N also isn't the
problem). Perhaps also a buggy PROM version? Which version do you have
in your 5000/150 ? The 5000/150 I have seems to hang just before calling
        jal loadmmu
or on return from the preceding instruction
        jal prom_init
in arch/mips/kernel/head.S as the last instruction in prom_init is 
definitely executed (I inserted a prom_printf there) and the next one in
loadmmu (hacked another prom_printf in there) isn't - maybe a stack
problem ?


<Prev in Thread] Current Thread [Next in Thread>