[Top] [All Lists]

Re: New DECStation root image

To: (Douglas S. Meade)
Subject: Re: New DECStation root image
From: Karel van Houten <>
Date: Sun, 23 May 1999 15:42:35 +0200 (MET DST)
In-reply-to: <>
Hi Doug,

Thanks for your reaction!

Doug wrote:
> 2. The NFS connection (I have a RedHat 5.1 Intel as server) seems
> a little flaky.  Several times I was installing a package using 
> RPM, and it would die with "Illegal Instruction (core dumped)"
> or "Segmentation Fault (core dumped)".  Strangely, when you 
> tried it again, it often worked, and when I got to the point of 
> mounting the root file system on a SCSI disk, the rpm commands
> worked on every package first try.  So I think it is the NFS 
> connection.  
Did you get any NFS error messages on the console or /var/log/messages?
I had NFS problems when running over NFS root, but this resulted in
slowdowns (time-out), but never a fatal error.

> 3. fdisk, cfdisk, vipw and several other commands don't work.  It's
> interesting that they don't always give the same error message.  For
> example, I tried fdisk several times.  I got one of the three messages:
> Bus error, Segmentation fault, or Illegal instruction.  Which one seems
> to be random, but it's mostly Segfault.  I've never observed this on 
> Intel/Linux.  Usually if a program segfaults once, it always does.
I think the util-linux packaged I used to create the root image was
compiled for R4k procs. Please try the new util-linux rpm package on
my web site 

> 4. Something in the shutdown sequence doesn't seem to be correct, 
> although I'm going to try and track this one down myself.  If 
> root is mounted NFS, it goes into a loop saying 
> "RPC: sendmsg returned error 128"
I think you are trying to remount a NFS mounted FS read-only, this might
be an oversight of me checking the rc files.

> If I mounted the SCSI, it comes back up on the next boot saying
> not cleanly unmounted, and this drops me into maintenance mode.  
> Unfortunately, e2fsck also randomly gives a segfault or illegal
> instruction, so you have to do it several times.  It works eventually.
This is strange. What type of SCSI controller do you use?

> 5. Trying to copy large files (linux source) over the NFS link causes
> either segfault, illegal instruction, or bus error.  Again, which seems
> to be random.  Trying to ftp the same file leads to segfault, so I 
> haven't been able to get the linux source image on my SCSI disk yet.
> Aside from these few observations, everything is working fairly well,
> and I had the system up for almost a day yesterday.
Mmm. You seem to have network and SCSI problems. Could it be a hardware

What DECStation are you using?

Karel van Houten

The box said "Requires Windows 95 or better."
I can't understand why it won't work on my Linux computer. 

<Prev in Thread] Current Thread [Next in Thread>