[Top] [All Lists]

Re: New DECStation root image

To: "Houten K.H.C. van (Karel)" <>
Subject: Re: New DECStation root image
From: "Douglas S. Meade" <>
Date: Fri, 21 May 1999 15:27:11 -0400 (EDT)
In-reply-to: <>

Thanks a lot for putting this up.  It's a big jump forward from the 
January image.  If you don't mind a somewhat lengthy post, here is
what I've been able to find on my DS5000/25:

1. The system now mounts NFS root and goes into multi-user mode
to where you can login at the console by hitting the break key
(Ctrl-\, B in Kermit).  You can telnet and login now as well.  
This is starting to get exciting!

2. The NFS connection (I have a RedHat 5.1 Intel as server) seems
a little flaky.  Several times I was installing a package using 
RPM, and it would die with "Illegal Instruction (core dumped)"
or "Segmentation Fault (core dumped)".  Strangely, when you 
tried it again, it often worked, and when I got to the point of 
mounting the root file system on a SCSI disk, the rpm commands
worked on every package first try.  So I think it is the NFS 

3. fdisk, cfdisk, vipw and several other commands don't work.  It's
interesting that they don't always give the same error message.  For
example, I tried fdisk several times.  I got one of the three messages:
Bus error, Segmentation fault, or Illegal instruction.  Which one seems
to be random, but it's mostly Segfault.  I've never observed this on 
Intel/Linux.  Usually if a program segfaults once, it always does.

4. Something in the shutdown sequence doesn't seem to be correct, 
although I'm going to try and track this one down myself.  If 
root is mounted NFS, it goes into a loop saying 
"RPC: sendmsg returned error 128"
If I mounted the SCSI, it comes back up on the next boot saying
not cleanly unmounted, and this drops me into maintenance mode.  
Unfortunately, e2fsck also randomly gives a segfault or illegal
instruction, so you have to do it several times.  It works eventually.

5. Trying to copy large files (linux source) over the NFS link causes
either segfault, illegal instruction, or bus error.  Again, which seems
to be random.  Trying to ftp the same file leads to segfault, so I 
haven't been able to get the linux source image on my SCSI disk yet.

Aside from these few observations, everything is working fairly well,
and I had the system up for almost a day yesterday.

Thanks again,


On Thu, 20 May 1999, Houten K.H.C. van (Karel) wrote:

> Hi all,
> I have now uploaded the new declinuxroot-990518.tgz to 

<Prev in Thread] Current Thread [Next in Thread>