[Top] [All Lists]

Re: Still no-go/gcc 2.7.2/binutils 2.8.1

Subject: Re: Still no-go/gcc 2.7.2/binutils 2.8.1
From: Harald Koerfgen <>
Date: Fri, 01 Jan 1999 16:16:57 +0100 (MET)
In-reply-to: <>
Organization: none
Reply-to: "Harald Koerfgen" <>
Hi Florian,

On 31-Dec-98 Florian Lohoff wrote:

> First the machine boots correct and afterwards suddenly i havnt
> got an arp entry asking for it on the ethernet and nobody answering ...
> *Aaaaaaaarghl*
> Ok - got it - The machine wont answer arp requests on tftp download
> and it seems that the development kernels (running 2.2pre1ac4/i386)
> do have very small arp timeouts ... When i hardcode the MAC Addr
> in my arp table it fully downloads the kernel ...

Hmmm...., I am still using 2.0.32.
> The 5000/150 shows me a "Launching Kernel"
> "This is a 5000/1xx" .. and stops ...
> The 5000/260 shows me a "Launsching kernel ..."
> "This DECstation is a DS5000/2x0" and stops ... Hmm

Well, that one should be easy. I guess you forgot to tell the kernel which
console device to use. Actually the numbering of the serial ports is
ttyS[01] - mouse and keyboard, ttyS2 - port #3, ttyS3 - port #2 for
5000/1xx and 5000/2x0 and the only serial port on a 5000/xx (Personal
DECstation) is ttyS0. Linux, by default, chooses the first port capable of
beeing a console device, which is ttyS0. This won't work on your machines.

>>boot 3/tftp/... console=ttyS2 root=/dev/ram

should do the trick. Yes, you have to tell the kernel which is the root fs
too. Unless..., well see my other posting :-)

And, Florian, DECstation-Linux isn't generic i.e., you have to compile the
source tree with the right CPU selected. That means two kernels for you,
one with CONFIG_CPU_R3000 for your '240 and one with CONFIG_CPU_R4xx0 for
your '150.

Happy new year.

<Prev in Thread] Current Thread [Next in Thread>