[Top] [All Lists]

Build Crosscompiler/useful results

Subject: Build Crosscompiler/useful results
From: Florian Lohoff <>
Date: Fri, 25 Dec 1998 23:06:38 +0100
Ok - again.

What i tried:

binutils 2.8.1 with patch on the site
+ the patch in (and without the last)

gcc 2.7.2 with the patch on + the 
crosscompile patch from 
(also tried

egcs 1.0.2 with the mips patch.


I can compile the utilities correctly and install it.

gcc bombs out with
mipsel-linux-gcc -D__KERNEL__ -I/data/mips/src/linux-2.1.121-pre2-flo/include
-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -G 0 -mno-abicalls -fno-pic
-mcpu=r3000 -mips1 -pipe  -c -o init/main.o init/main.c
/data/mips/src/linux-2.1.121-pre2-flo/include/linux/sched.h: In function
In file included from init/main.c:17:
/data/mips/src/linux-2.1.121-pre2-flo/include/linux/sched.h:528: `current'
undeclared (first use this function)
/data/mips/src/linux-2.1.121-pre2-flo/include/linux/sched.h:528: (Each
undeclared identifier is reported only once


/data/mips/src/linux-2.1.121-pre2-flo/include/linux/mm.h:353: `current'
undeclared (first use this function)
make: *** [init/main.o] Error 1

egcs produces a correct nbImage but the tftp boot stops in the
middle. As experiences from my previous trys to boot something i know
that the /150 show different segments (text, code ???) but now it only
shows one and stops when i would expect the second to show up.

Ok gurus - What do i do now ?

Very much frustrated ...
Florian Lohoff                  +49-5241-470566
Good, Fast, Cheap: Pick any two (you can't have all three).  (RFC 1925)

<Prev in Thread] Current Thread [Next in Thread>
  • Build Crosscompiler/useful results, Florian Lohoff <=