[Top] [All Lists]

RE: linux on PERSONAL DECstation5000/33

Subject: RE: linux on PERSONAL DECstation5000/33
From: Kristoff Bonne <>
Date: Mon, 11 May 1998 16:04:37 +0200 (MET DST)
Reply-to: Kristoff Bonne <>

> Date: Sat, 09 May 1998 17:48:03 +0200 (MEST)
> From: Harald Koerfgen <>
> To: Kristoff Bonne <>
> Subject: RE: linux on PERSONAL DECstation5000/33
> Cc:

> On 07-May-98 Kristoff Bonne wrote:
>> I've tried booting a linux-kernel on my personal DECstation 5000/33, but it 
>> failed.
>> What I did was this:
>> - I FTPed the binary image of the 2.1.14pl2 kernel from 
>> - copied it onto the rz-25 drive of my DS5000 (currently running NetBSD 
>> 1.2), 
>> and called it 'vmlinux'
>> - did a 'halt' and 'boot 3/rz4/vmlinux'.
>> - I got the following messages:
>> 3/rz4/vmlinux: bad magic 40162
>> Can't boot '3/rz4/vmlinux'
>> Is this because I copied the file onto my disk (and hence don't use TFTP)

> No, this method works with proper kernel images. I am using this to test
> kernels on my DS 5000/240, which doesn't boot via tftp. I guess there is
> something wrong with the binary image, maybe still zipped?

Well, I tried it again, to be sure:
I 'lynx'ed the binary kernel from, did 'gzip -d 
vmlinux-2.1.14-070298.gz' and did a 'mv vmlinux-2.1.14-070298 vmlinux'.

After that:
$ halt
>>> boot 3/rz4/vmlinux

The same result.

Can't it be because of some part of the 'disklabel' code of the netbsd 1.2.
(you know the 'bootrz' and 'rzboot'-files?)

I've read things about the 'milo' in this list. (Or am I mixing-up some things!)

Cheerio! Kr. Bonne.
Bonne Kristoff                              belgacom multimedia
(C=BE,A=RTT,P=RTTIPC,S=BONNE,G=Kristoff)    operations belbone                  fax: +32 2 2024123

<Prev in Thread] Current Thread [Next in Thread>