[Top] [All Lists]

Re: crtbegin.o

Subject: Re: crtbegin.o
Date: Sat, 13 Dec 1997 09:05:25 +0100
In-reply-to: <>; from Ryan on Fri, Dec 12, 1997 at 09:35:21PM -0500
References: <> <>
On Fri, Dec 12, 1997 at 09:35:21PM -0500, Ryan wrote:

> After hours of meticulous downloading, I grabbed all the RPMs I could from

Hehe, shop for a watercooled NIC:

[root@tbird redhat]# du -s RPMS SRPMS
174930  RPMS
207239  SRPMS

Btw, after about a week of destruction testing:

[root@tbird redhat]# uptime
  8:54am  up 16 days,  2:20,  2 users,  load average: 0.00, 0.00, 0.00
[root@tbird redhat]#

No scratches, still supershiny ...

> and began trying to install them.  Most worked like a
> charm, including many that I couldn't get to compile myself.  .  However,
> one big problem has appeared:  I can't compile any programs because
> /usr/lib/crtbegin.o is now missing.  I tried recompiling glibc-2.0.4 and
> it didn't produce the file.  After looking on a Redhat/ALPHA box,
> /usr/lib/crtbegin.o belongs to glibc.rpm; what gives?

It's actually produced as part of the GCC installation procedure.

> Anyway, I'm looking for that file, if anyone can send it or tell me where
> to find it.

It's being installed as part of the GCC installation procedure.  Quick
fix: steal the files from a crosscompiler installation, if you have one.
As Tim already said the missing files crtbegin.o, crtbeginS.o, crtend.o
and crtendS.o should be part of gcc-2.7.2-1.mips.rpm; I'll upload a new
package rsn.


<Prev in Thread] Current Thread [Next in Thread>