[Top] [All Lists]

DS2100 woes ...

Subject: DS2100 woes ...
From: Michael Engel <>
Date: Mon, 9 Jun 1997 22:23:48 +0200 (MET DST)
Hi all,

first the good news: 

Dave Voth, the former chief developer of the DECstation 5000/120,125,133 has 
found some documentation on these machines and is willing to send it to me
(hmmm, I didn't tell him I'm living in Germany - perhaps he better sends it
to Maddog ???).

I finally have a DECstation 2100 of my own here - 24 MB RAM, mono frame
buffer and a HUGE RZ23 hard disk ;) (about 100MB, I think) - thanks to
my programming languages professor here (who is also using Linux at home ;-))
which I'm trying to set up now.

I tried to run the kernel on a DS3100 at University this afternoon.
The kernel loads and then does some _very_ funny things:

- No output whatsoever is made
- I can press return several times. All characters I type in are echoed.
  After pressing return several times, I get part of the output of the 
  printk of the cache sizes. After that, the machine crashes.
  I _think_ the number of returns I have to press is related to the number of
  printk statements that were executed before that cache probing line.
  (I removed one of the printk's and had to press return one time less - this 
  was reproducable).

I yet have to reproduce this on the 2100 here - on this machine, the kernel
hangs completely. This may be related to the fact that I use a self-built 
cross compiler on Solaris 2.5.1 at University and my intel Linux box with
Ralf's cross-compile envrionment at home.
So, I tried to load the 2.1.1 kernel which worked fine.
(I got a defective DS2100 before, so I was suspicious ;-)). I added a call to a
routine which simply clears the screen immediately after dec_entry - this 
routine is not executed ... _Very_ funny ... What may go wrong there ???
I'm totally confused ...

On the subject of the defective DS2100 - this machine loads the kernel via
tftp and then crashes somewhere in the boot ROM (address 0xbc....). That 
DECstation has a V7.00 PROM, the one I'm using now has a 7.01 PROM. May
that cause the problems ???


<Prev in Thread] Current Thread [Next in Thread>
  • DS2100 woes ..., Michael Engel <=