[Top] [All Lists]

Re: R3000 code in 2.0.6

Subject: Re: R3000 code in 2.0.6
From: Systemkennung Linux <>
Date: Sun, 8 Sep 1996 03:08:53 +0200 (MET DST)
In-reply-to: <> from "Paul Antoine" at Sep 7, 96 07:49:57 am
> I've been trying to compile the 2.0.6 release, in preparation for getting
> the DECstation code working again and have run into a snag.  I'm getting
> the following errors:
> mipsel-linux-gcc -D__KERNEL__ -I/usr/home/mips/linux-2.0.6/include -Wall 
> -Wstrict-prototypes -O2 -fomit-frame-pointer -G 0 -mno-abicalls -fno-pic 
> -mcpu=r3000 -mips1  -c r3000.S -o r3000.o
> r3000.S: Assembler messages:
> r3000.S:78: Warning: .type pseudo-op used outside of .def/.endef; ignored
> r3000.S:78: Error: Rest of line ignored. First ignored character is `h'.
> r3000.S:140: Warning: Macro used $at after ".set noat"
> r3000.S:142: Warning: Tried to set unrecognized symbol: push
> r3000.S:142: Warning: Tried to set unrecognized symbol: pop
> :
> :
> :
> and so on.  Since the code in the lines mentioned above is identical to
> the 1.3.62 version, I'm assuming that there are changes elsewhere in
> the source tree that are broken.  Any hints?

The kernel source tree is ok.  I just forgot to upload the new binutils
without the a.out support.  Sorry, I'll have to let you wait at least
another day because this university hasn't yet heard the word of
RTS/CTS handshake ...


<Prev in Thread] Current Thread [Next in Thread>